
 

Getting Started 
Excel 2010  

 

Microsoft
®

 Excel
®

 2010 delivers rich, new and enhanced data analysis and visualization tools. Whether you’re analyzing 

statistical data or keeping track of your personal or business expenses, with Excel 2010 you can analyze, manage, and 

share information in more ways than ever before. Excel 2010 can help you keep better track of your information and 

make better decisions. Easily publish your Excel workbooks to the Web and extend the ways you can share and work 

together with friends and colleagues. Your work is never farther away than your closest Web browser or smartphone—

work when and where you want.
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Backstage View: 
Prep your work for prime time 

 
Get centralized access to prepare your workbooks such as save, share, print, and 

publish or customize your Excel experience in Microsoft Office Backstage™ view. 
 

 

 

 

 File tab: Opens Backstage view. Click any Ribbon tab to return to the main view. 

 Backstage tabs: Fast, easy, and organized access to tools and options that were previously 

spread across several locations. 

 ● Info: Obtain information about your workbook, such as file properties, and get a single 

access point to new and improved file management tools, including the ability to recover 

unsaved versions of your workbooks. 

● Recent: Displays a list of recent saved workbooks and file locations. Click the pushpin icon 

next to a workbook to ‘pin’ it to the list and move it to the top so it’s readily available. 

● New: Quick access to your templates and a rich set of built-in templates for starting new 

workbooks. Also find online and community-submitted templates. 

● Print: Print options and Print Preview are now combined in one effortless view. 

● Save & Send: Easily save your files in other formats, such as PDF or XPS. Or share your 

workbooks via e-mail, save to Microsoft
 
SharePoint

® 
Server, Microsoft SharePoint Online
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or your Windows Live™ SkyDrive™. 

● Help: Get application help and links to other online self-help resources, such as training 

tutorials. Also find information about the version you are running, activation, and licensing 

information. 

● Options: Offers extensive options for setting your preferences, including the ability to 

customize the Ribbon and Quick Access Toolbar. 
 

 

 

 
Tip: Get help for using the Ribbon, including how to customize the Ribbon in Excel 2010, in the Office 2010 Getting Started Guide 

or on Office.com. 
 

Turn complexity into clarity:  
Make your work stand out 

 
New visualization and analysis tools help you analyze your information more 

effectively and create compelling visualizations. 
 

Create powerful data insights and visuals 

The Sparklines feature in Excel 2010 enables 

you to present a clear and compact visual of 

your data in small charts within a worksheet 

cell. 

1. Select the cells in which you would like to 

place Sparklines. 

2. On the Insert tab, in the Sparklines group, 

click Line, Column, or Win/Loss.  
 

3. In the Create Sparklines dialog box, select the associated values from which to 

create Sparklines. (Do not include data labels when selecting associated values.) 

● To customize your Sparklines: Select cells containing Sparklines. On the Sparkline 

Tools Design tab, which displays automatically, find options to change the 

Sparkline type, style, and more. Use the Clear options to remove Sparklines. 
 

Illustrate important trends and highlight data exceptions  

New styles, icons, 

and data bar options 

help you quickly 

visualize and 

comprehend data. 

1. Select a range of 

values.   

2. On the Home tab, in the Styles group, click Conditional 

Formatting. 

3. Select a conditional format from an available gallery. 

Tip: Use the More Rules option at the bottom of a gallery to 

further customize your conditional formatting. 
 

 

  

                                                            
1
 Web and smartphone access require an appropriate device and some functionality requires an Internet connection. Web functionality uses Office Web Apps, which require a supported Internet 

Explorer®, Firefox, or Safari browser and either SharePoint Foundation 2010, SharePoint Online (Office 365) or a Windows Live ID. Some mobile functionality requires Office Mobile which is not 

included in Office 2010 applications, suites, or Office Web Apps. There are some differences between the features of the Office Web Apps, Office Mobile and the Office 2010 applications. 
2
 Available in Microsoft Office 365 service plans. Visit www.office365.com for more information. 

http://www.office365.com/
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Find your answers faster: 
Harness the power of filtering 

 
Analyze your information with fewer clicks than before and spend less time sifting 

through large data sets.  
 

 
Dynamically filter your PivotChart views 

Excel 2010 takes the popular PivotChart, used for visual analysis and reporting, 

 

one step further. You can now filter 

directly on your PivotChart using 

new interactive buttons. 

● On a PivotChart, click the 

interactive buttons to access 

filtering options. 

To show or hide interactive buttons 

on a PivotChart: 

● On      the     PivotChart    Tools  

Analyze tab, in the Show/Hide group, click the top half of Field Buttons to 

show or hide all buttons on your PivotChart.  

To show or hide individual buttons on a PivotChart: 

● On the PivotChart Tools Analyze tab, in the Show/Hide group, click the 

bottom half of Field Buttons to access additional options. 
  

  

 

Instant Search for your filters 

Easily find relevant items among 

potentially thousands or millions of 

available choices in tables, 

PivotTable or PivotChart views. 

To access the Search Filter: 

● In any active table or PivotTable, 

click the arrow  that 

appears on row or column 

headings.  

● In a PivotChart, click an 

interactive button to access the 

Search Filter.  

Note: Use the Add current selection to filter option on subsequent 

searches to add additional filter items and maintain your previously 

filtered list. 

Drill down to the right details 

Enhanced PivotTable and PivotChart filtering lets you intuitively filter large  amounts  of data in fewer steps than before so you  can quickly find  just  
 

 

the relevant information you need. 

To insert a Slicer: 

1. Place your cell pointer in a PivotTable. The PivotTable Tools automatically display.  

2. On the Options tab, in the Sort & Filter group, click Insert Slicer.  

3. Select your desired filter field, or select multiple fields to insert more than one Slicer, and click OK. 

For PivotChart views: 

● Select a PivotChart. Find Insert Slicer on the PivotChart Tools Analyze tab, in the Data group. 
 

Note: To select fields in a Slicer, drag through adjacent fields. For nonadjacent fields, hold the Ctrl key and click each field you wish to filter. 
 

 

Streamline your tasks: 
Get things done faster 

 
Accomplish your work more seamlessly and in fewer clicks than before through Paste 

with Live Preview. 
 

 

 

Preview before you paste 

Save time when reusing content across applications using Paste with Live Preview. Determine how your pasted content will look 

prior to actually pasting and get it right the first time.  

1. On the Home tab, in the Clipboard group, click the arrow beneath the Paste button or right-click at the insertion point to 

view available Paste Options. 

2. Hover your mouse pointer on individual Paste Options to preview results and click your preferred option to paste. As you 

point to options, a ScreenTip appears with the name of that option. 

Note: Available Paste Options change contextually to best fit the content you are reusing. 
 

 

Better protect yourself from 

malicious files 

 
Office 2010 introduces Protected View to help you make more informed decisions 

before exposing your computer to possible vulnerabilities. 
 

Files received in e-mail, or originate from an Internet 

source, are automatically  opened  in a  Protected View  

so you can view the content before you choose whether to enable the 

file for editing. 

1. Opening in Protected View is automatic. A message bar appears 

below the Ribbon to indicate that your file has been opened in 

Protected View. 

2. If you trust the contents and choose to proceed with editing, click 

Enable Editing on the message bar to close Protected View. 

To manage Protected View settings: 

1. Click the File tab to open Backstage view. 

2. Click Options, then in the Options dialog box, click Trust Center. 

3. On the right, click the Trust Center Settings button.  

4. In the Trust Center dialog box, click the Protected View tab to display 

options for enabling Protected View. 
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Don’t do the same  

work twice 

 

You can now recover unsaved versions of your Excel 2010 workbooks—even if your file 

was never previously saved. 
 

Work on that workbook for a while and then accidentally close without saving? No 

problem. Excel 2010 lets you recover unsaved workbooks as easily as opening any file. 

And, for previously saved files, you can view up to five autosave versions of your files as 

you work, right from Backstage view.  

To recover autosave versions (created while working on previously saved files): 

1. Click the File tab to open Backstage view.  

2. On the Info tab, under the Versions heading, view available autosave versions. 

3. Click an available autosave version to open the file.  

To recover unsaved workbooks (workbooks that were never previously saved): 

1. Click the File tab to open Backstage view. 

2. On the Info tab, click Manage Versions to access Recover Unsaved Workbooks. 

Note: If you are working on a file that has never been previously saved, when you click 

Manage Versions you’ll also see an option for Delete All Unsaved Workbooks.  

Note: Recovering available unsaved workbooks and autosave versions requires you elect to save AutoRecover information. To keep an autosave version until your next editing session you must also 

elect to keep the last autosaved version when you close without saving. To access these options, in Backstage view click Options and then click Save. 

 

 

 
Tip: Also recover or manage your unsaved workbooks from the Recent tab in Backstage view. Click Recover Unsaved Workbooks 

at the bottom of the Recent Places list to open your UnsavedFiles folder. 

 
 

Can your workbook be read 

by those with disabilities? 

 
Use the Accessibility Checker and inspect your workbook for content that may be 

difficult for those with disabilities to read.  
 

 

The new Accessibility Checker inspects your workbook for inaccessible content. When issues are 

found, the tool provides an explanation of the issue along with step-by-step help for correcting it.  

To display the Accessibility Checker and correct accessibility issues: 

1. Click the File tab to open Backstage view.  

2. On the Info tab, click Check for Issues. 

3. Click Check Accessibility to return to your workbook and view the Accessibility Checker task 

pane. 

4. In the Accessibility Checker task pane, click a specific error or warning. 

5. Read the Why Fix section to better understand the inspection results. 

6. Follow the steps in the How to Fix section near the bottom to correct the issue. 

 
 

Analyze enormous 

quantities of data  

 
PowerPivot for Excel 2010, a free add-in, is a data analysis tool that delivers 

unmatched computational power directly within Excel. 
 

PowerPivot enables you to empower your insight and decision-making, to share and 

collaborate with confidence, and to help improve IT efficiency. 

● Excel-based in-memory analysis. Overcome existing limitations of large data analysis on 

the desktop with efficient compression algorithms to load even the biggest data sets into 

memory. 

● Data Analysis Expressions (DAX). Places powerful relational capabilities into the hands of 

power users who want to create advanced analytics applications such as 

SamePeriodLastYear(), ClosingBalances(), Previous Day(), and more. 

● Hit the ground running. Leverage new Excel features such as Slicers and those you already 

know, including the Ribbon, PivotTable, and PivotChart views. 

To obtain the free PowerPivot for Excel 2010 add-in: 

● Visit: www.powerpivot.com.  
 
 

http://www.powerpivot.com/
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Communicate more,  

cobble less 
 

Easily initiate an instant conversation with another author without leaving Excel 2010 

through Microsoft Lync 2010 right from Backstage view. 
 

The power of presence 

Wherever you see presence information  , you can point to the person’s name and display their 

contact card which provides a variety of communication options, such as instant messaging and 

voice calls. 

1. Open a workbook and click the File tab to open Backstage view.  

2. On the Info tab, in the Properties pane, hover your mouse over a document property with a person’s name, such as Author or Last Modified By, to 

display the new contact card. Expand the contact card for even more details. 

Note: Instant messaging and presence information requires one of the following: Microsoft Lync Server 2010 or Lync Online (Office 365) with Microsoft Lync 2010, Microsoft Office Communications 

Server 2007 R2 with Microsoft Office Communicator 2007 R2, Windows Live Messenger, or another instant messaging application that supports IMessenger. Voice calls require either Lync Server 2010 

or Lync Online (Office 365 includes PC-to-PC audio/video only) with Lync 2010, Office Communications Server 2007 R2 with Office Communicator 2007 R2 or an instant messaging application that 

supports IMessengerAdvanced. 

 

 

 

Tip: Click the push pin near the top of the contact card to keep it visible and readily available. 

 

Break down barriers: 
Work together in new ways 

 
Excel Web App offers easy ways to bring people together to increase work quality and 

work simultaneously on workbooks.  
 

 

 

Stop waiting your turn and co-

author instead 

You no longer have to worry about 

someone locking you out of a 

workbook while they edit it. 

Microsoft Excel Web App lets you 

work in unison and see changes 

from others appear in near real-

time. Save your Excel workbooks 

online and co-author with ease. 

To co-author a workbook: 

● Co-authoring is automatically enabled when multiple authors open the same 

file from a SharePoint Server 2010 or SharePoint Online site. 

To view current authors: 

● The total number of authors editing the workbook appears in the status bar. 

Click the author count to view author names. 

For more on using Excel Web App, see the Office Web Apps Getting Started 

Guide. 

Note: Co-authoring requires SharePoint Foundation 2010 or SharePoint Online (Office 365) for business use or 

a free Windows Live ID for personal use.  
 

Publish and share through Excel Services 

SharePoint Excel Services lets 

you share your easy-to-read 

workbooks in a Web browser 

with your team while 

maintaining a single version of 

the workbook. 

To publish to Excel Services:  

1. Click the File tab to open Backstage view. 

2. On the Save & Send tab, click Save to SharePoint. 

3. Click Publish Options. 

4. In the Publish Options dialog box, on the Show tab, select 

specific sheets or items in the workbook you wish to publish. 

5. On the Parameters tab, specify cells that should be editable 

in the browser. 

Note: Editable cells must be named ranges consisting of a single 

cell and contain a value. 

Note: Microsoft Office Professional Plus 2010, Microsoft Office Professional Academic 

2010, or Microsoft Excel 2010 when purchased as an individual application is required 

for publishing to Excel Services from Excel 2010.  
 

 

 

Keyboard shortcut tips Miscellaneous keyboard shortcuts 

● Press the Alt key to view KeyTips. KeyTips appear on the Ribbon with 

letter or number combinations you press sequentially on the keyboard to 

execute commands. Press a KeyTip to activate a Ribbon tab and then 

press the KeyTip for your desired command. 

Note: KeyTips are also available for the Quick Access Toolbar and 

Backstage view. 

● Hover your mouse pointer on Ribbon commands and find keyboard 

shortcuts in the ScreenTips. (Note not all commands have shortcuts.)  

● Many common commands use Ctrl + the first letter of the command. 

Here are a few examples: 

New: Ctrl + N ● Open: Ctrl + O ● Save: Ctrl + S ● Print: Ctrl + P 

Below is a sampling of the many keyboard shortcuts Excel has to offer. To 

find additional keyboard shortcuts: Press F1 to open Help and then 

search for Keyboard Shortcuts. 

● To insert the AutoSum function: Press Alt + = 

● To start a new line in the same cell: Press Alt + Enter 

● To select the current region: Press Ctrl + Shift + Spacebar 

● To toggle the size of the Excel formula bar: Press Ctrl + Shift + U 

● New shortcuts for working with shapes: 

Resize: Shift + arrow keys ● Rotate: Alt + right or left arrow keys 

Tip: To resize or rotate in smaller increments, add Ctrl to these key 

combinations. 

 


